[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[AUCTeX] Re: MikTex and Auctex 11.85; tex-auto-global and style-path

From: Sivaram Neelakantan
Subject: [AUCTeX] Re: MikTex and Auctex 11.85; tex-auto-global and style-path
Date: Sun, 30 Mar 2008 16:15:07 +0530
User-agent: Gnus/5.110007 (No Gnus v0.7) Emacs/22.2 (windows-nt)

Ralf Angeli <address@hidden> writes:

> * Sivaram Neelakantan (2008-03-30) writes:

> Are you sure the "c:" part will work?

Fixed that.


>> 1.  I had the graphicx package defined and so did a C-c C-n.  That didn't 
>> work
> When you load the file, do you see in the *Messages* buffer graphicx.el
> being loaded?
> Are there any errors in the *Messages* buffer after starting Emacs or
> loading a LaTeX file?

Arrrggh! I *never* checked the Messages buffer.  It appears that I was
loading an year old tex-site.el file.  Removing it, and I was able to
get the completion working correctly!  The old one had all those wrong
paths.  I knew when I posted my question, there was something
Himalayan stupid about it.


> Isn't "c:/gnu/elisp/" the directory where you keep the AUCTeX sources?
> Did you actually run `make' and `make install'?

Yes, I regenerated everything, just to be sure

./configure --with-emacs=c:/gnu/emacs-22.1/bin/emacs --disable-preview
--with-texmf-dir=c:/MiKTeX-2.7/miktex/tex/ --prefix=c:/gnu/

$ echo $PATH

> Does this mean the "c:/gnu/elisp/" stuff is in the Makefile?  Could you
> perhaps send the part of the Makefile where the variables like `prefix'
> and `styledir' are defined?

--8<---------------cut here---------------start------------->8---
prefix = c:/gnu/$(null)
exec_prefix = ${prefix}$(null)
libdir = ${exec_prefix}/lib$(null)
packagedatadir = c:/gnu/emacs-22.1/site-lisp//auctex$(null)
datarootdir = ${prefix}/share$(null)
datadir = ${datarootdir}$(null)
localstatedir = ${prefix}/var$(null)
infodir = ${datarootdir}/info$(null)
lispdir = c:/gnu/emacs-22.1/site-lisp/$(null)
packagelispdir = c:/gnu/emacs-22.1/site-lisp//auctex$(null)
packagedatadir = c:/gnu/emacs-22.1/site-lisp//auctex$(null)
packagedir = no$(null)
autodir = ${localstatedir}/auctex$(null)
styledir = $(packagedatadir)/style
AUCTEXDATE = 2008-02-10
--8<---------------cut here---------------end--------------->8---


I still have 2 issues

1. I still get those ^Ms in the log C-c C-l
2. TEx-submit-bug-report fails with

Loading sendmail...done
byte-code: Opening output file: no such file or directory,

c:/gnu/emacs-22.1/lisp/mail/reporter.el is what is being read when I
do a M-x ffap in c:/gnu/emacs-22.1/site-lisp/auctex/tex.el


dired-x-submit-report  too fails with the same error.  This *appears*
 to be an error independent of AucTeX.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]