auctex
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [AUCTeX] Fold citep


From: Joost Kremers
Subject: Re: [AUCTeX] Fold citep
Date: Sun, 18 May 2008 20:13:22 +0200
User-agent: Mutt/1.5.16 (2007-06-09)

hi ralph,

sorry for the late reply. i haven't really had time yet to look at your
message...

On Sat, May 10, 2008 at 09:50:18PM +0200, Ralf Angeli wrote:
> I found the respective message:
> <URL:http://mid.gmane.org/20070116005434.GA20788%40teuctli>
> 
> Back then you wrote that the patch is not ready yet.

yes, the patch worked for my situation, but i was hoping to get some
feedback. since no-one replied, i figured you guys found it too specialist
functionality, so i didn't look at it any further.

>  I think providing
> the possibility to call a function on the macro arguments is a nice idea
> for "power users".  It would probably be good to provide easier ways for
> customizing as well.  In your message you mentioned `format'.  If we
> could use that for the spec string it would be pretty easy for people
> not proficient in Lisp to cope with challenges as described by Rasmus.
> I haven't checked if this is possible, though.

i'm sure it's possible, but it might not be so easy to implement. you'd
want a user to be able to specify something like "(#1)", in which #1 is
going to be replaced with the first argument. this needs to be converted in
the proper format string + argument to feed to FORMAT. i don't immediately
see an easy way to do that...

> By the way, do you have copyright assignment papers for AUCTeX on file?

no, i don't. but you're happy to use those few lines of code i wrote in any
way you see fit. ;-)

i applied the patch to tex-fold.el from 11.85, which went fine. folding a
region works as intended, but i'm having a problem with TeX-fold-buffer.
the problem appear to be in the call to jit-lock-fontify-now.

it seems that on my emacs, the combination of jit-lock-fontify-now and
auctex is problematic. when opening a latex file, the file seems to be
fontified properly, but the *Messages* buffer does show errors:

Error during redisplay: (void-function nil) [4 times]

eval'ing (jit-lock-fontify-now) in an auctex-controled latex buffer gives
the same error (in fact, the debugger is started). doing the same in e.g. a
lisp buffer doesn't give any problems.

calling TeX-fold-buffer (C-c C-o C-b) in a auctex-controlled latex buffer
yields the following error in the *Messages* buffer:

font-lock-fontify-keywords-region: Symbol's function definition is void: nil

i'm running a cvs unicode emacs (23.0.0.1), so i'll try upgrading to the
latest version before i make an official bug report. unless you have an
idea what might be wrong...


-- 
Joost Kremers, PhD
University of Frankfurt
Institute for Cognitive Linguistics
Gr√ľneburgplatz 1
60629 Frankfurt am Main, Germany




reply via email to

[Prev in Thread] Current Thread [Next in Thread]