[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCHES] {maint} honour configure-time AUTOCONF and AUTOM4TE (was:

From: Stefano Lattarini
Subject: Re: [PATCHES] {maint} honour configure-time AUTOCONF and AUTOM4TE (was: Re: make check failures)
Date: Mon, 30 May 2011 23:53:03 +0200
User-agent: KMail/1.13.3 (Linux/2.6.30-2-686; KDE/4.4.4; i686; ; )

On Sunday 29 May 2011, Stefano Lattarini wrote:
> [Adding automake-patches]
> On Saturday 28 May 2011, Graham Reitz wrote:
> > Hi Stefano,
> > 
> > Did you have a chance to take a look at the config and test logs?
> > (they are attached)
> >
> > I've been trying to figure it out without much success.
> >
> I think I've found the problem: the `' and `'
> "templates" (from which the `aclocal' and `automake' scripts are
> generated) fail to honour the AUTOCONF and AUTOM4TE defined at
> configure time, and simply use literal "autom4te" and "autoconf"
> instead.  This is a real bug in Automake's own build system, and
> is still present in the latest developement version.  The attached
> two-patches series (for maint) should fix it.  Graham, do you mind
> trying if it solves your problem?  I will push the patches shortly
> if there is no objection.
> Thanks,
>   Stefano
I've now pushed the patches after tweaking the ChangeLog entries.

Here are the updated ChangeLog entries:

  2011-05-29  Stefano Lattarini  <address@hidden>

      build: the user can override AUTOM4TE, AUTORECONF and AUTOUPDATE too
      Our build system allows the user to override AUTOCONF and AUTOHEADER
      at configure time, and honours these overrides in our testsuite.
      But it didn't do the same with AUTOM4TE, AUTORECONF and AUTOUPDATE.
      This change fixes that inconsistency.
      * (am_AUTOM4TE, am_AUTOUPDATE, am_AUTORECONF): New
      AC_SUBSTitutions.  Update comments.
      * tests/ ($AUTOUPDATE): Default to address@hidden@' now.
      ($AUTOM4TE): New variable, defaulting to address@hidden@'.
      ($AUTORECONF): New variable, defaulting to address@hidden@'.
      * doc/ ($(srcdir)/amhello-1.0.tar.gz): Update.

  2011-05-29  Stefano Lattarini  <address@hidden>

      automake, aclocal: honour configure-time AUTOCONF and AUTOM4TE
      Currently, the Automake's own configure script allow definition
      of AUTOCONF and AUTOM4TE, expected to point respectively to an
      autoconf and autom4te programs.  But while these definitions are
      honoured in the Automake's build systems and test suite, they
      were *not* honoured in the generated `automake' and `aclocal'
      scripts.  This behaviour, apart from being wrong in that it does
      not allow the user enough freedom in choosing his tools, also
      caused inconsistencies in the test suite, brining to spurious
      Problem reported by Graham Reitz on the automake list; see thread:
      * ($traces): Use address@hidden', not simply `autoconf'.
      * ($traces): Use address@hidden', not simply `autom4te'.
      * (do_subst): Substitute also address@hidden' and
      * NEWS: Update.
      * THANKS: Update.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]