[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

about requiring Perl 5.6 in Automake 1.9

From: Alexandre Duret-Lutz
Subject: about requiring Perl 5.6 in Automake 1.9
Date: Fri, 06 Feb 2004 23:29:08 +0100
User-agent: Gnus/5.1003 (Gnus v5.10.3) Emacs/21.3.50 (gnu/linux)

Right now, automake officially requires at least Perl 5.005.

Perl 5.005_03 will be 5 years old next month, and supporting it
is becoming painful.

The 1.8 release had a bug that caused it to fail with Perl
5.005_03 and despite numerous beta releases, it was only
reported later.

Recently it was reported that in some conditions, aclocal 1.8.2
will call a function that was introduced only in Perl 5.6.
Reinventing the wheel each time this happens is time consuming.

I'm considering dropping support for Perl 5.005 in the future
Automake 1.9, and require at least Perl 5.6.  Perl 5.6 will be 4
years old next month, so it does not sound like asking for the

How many people would be annoyed by this?  Is there any reason
why this would be a very bad idea?

I know some people are still using 5.005_03.  We'd have never
noticed the aforementioned breakages otherwise.  However I do
not know why they do.  Is there any reason why upgrading to
newer Perl versions would be undesirable?

PS: I'd still fix Perl 5.005_03 issues in 1.8.x.
Alexandre Duret-Lutz

reply via email to

[Prev in Thread] Current Thread [Next in Thread]