[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: useful bug reports

From: Harald Dunkel
Subject: Re: useful bug reports
Date: Tue, 15 Nov 2005 17:26:14 +0100
User-agent: Debian Thunderbird 1.0.7 (X11/20051019)

PS: Sorry, I pasted the wrong into the EMail, see below.

Harald Dunkel wrote:
> Hi Ralf,
> Ralf Wildenhues wrote:
>>Harald, please consider *providing more and useful information* if you
>>want help.  I for one can't read your mind, and almost every first post
>>of yours leaves me wanting for a crystal ball as to what has gone wrong.
>>This makes me for one be less and less enthusiastic about replying.
>>With newbies, or people where I do not know whether they are newbies or
>>not, one cannot expect more, at least the first couple of times they
>>post.  But you bee given hints before.  This is no service hotline.
>>I heartily recommend reading this (available in several languages):
>>We have now again wasted 5 messages without getting to the point of the
>>problem you encounter: I still have no clue what's going wrong on your
>>side, and I bet you aren't happy about the situation either.
> Sorry for not being more precise.
> Here is a sample.
>       AC_INIT(package,version)
>       AC_CONFIG_AUX_DIR([.])
>       AM_INIT_AUTOMAKE([foreign subdir-objects no-define])
>       AC_PROG_CC
>       AC_PROG_CPP
>       AC_AIX
>       AC_ISC_POSIX
>       AC_MINIX
>       AC_PROG_CXX
>       AM_PROG_CC_C_O
>       AM_PROG_LEX
>       AC_PROG_YACC
>       AC_CONFIG_FILES([Makefile])
>       AC_OUTPUT
>       noinst_PROGRAMS = hello
>       hello_SOURCES = hello.cxx
Should be
        noinst_PROGRAMS = hello
        hello_CPPFLAGS = -I/somedir
        hello_SOURCES = hello.cxx
> Autoconf is 2.59, plus Stepan's patch for c.m4, see attachment
> Automake is 1.9.6
> platform is Linux
> build platform is Windows, using MSVC 7.1.
> The patch provided by Stepan some months ago fixes
> AM_PROG_CC_C_O for Windows and MSVC, i.e. configure recognizes
> that -c -o doesn't work as expected for Bill Gates' compiler.
> Looking into the generated Makefile I see
>       CC = /somedir/compile cl.exe
> The compile script is necessary for both C and C++ code. But
> it is not copied by Automake. Nor does it set CXX accordingly.
> in the Makefile.
> The patch I had sent was an attempt to workaround the problem,
> but it is not sufficient. Any help would be highly appreciated.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]