[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Setting shared lib version not functioning

From: John Calcote
Subject: Re: Setting shared lib version not functioning
Date: Sun, 03 May 2009 22:08:58 -0600
User-agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20090223 Thunderbird/3.0b2


On 5/3/2009 12:40 PM, Gerald I. Evenden wrote:
I want to thank you all for the assistance, however I still find the libtool
manual not very illuminating.  In particular, I used section 7.3 in make my
release number and, in particular, item 5 related to adding an interface
since last release as causing an addition to "age."

The big problem here is the three number do not seem independent, which
compounds the problem.  Perhaps item 3 was what should have changes but item
5 clause was also true.
The numbers aren't independent at all. Don't try to make the library interface version components into a software revision number. The scheme is the way it is because the OS library loader uses the values in these fields to determine if a particular library will support a particular interface request. When a program attempts to load a library versioned 1.0.0, but the OS loader can only find 2.0.1, then the loader will go ahead and load 2.0.1 because the '1' in the age field indicates that this library supports 1.x interfaces as well as 2.x.

Jan answers the rest of your question in his response.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]