[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [avrdude-dev] [bug #34339] back to back avrdude commands fail on dra

From: Joerg Wunsch
Subject: Re: [avrdude-dev] [bug #34339] back to back avrdude commands fail on dragon_isp on Ubuntu 10.10
Date: Thu, 8 Dec 2011 12:44:33 +0100
User-agent: Mutt/1.5.20 (2009-06-14)

As Xiaofan Chen wrote:

> With libusb-compat, you do not need to change any codes. It is
> a wrapper for libusb-0.1 API, on top of libusb-1.0.

That's been my understanding, too.

But what do we have to do for this?  The configure script only tries
to test-compile a small code snippet that includes "usb.h", creates a
reference to usb_get_string_simple(), and then tries to compile and
link this against -lusb.  It doesn't care whether this usb.h and -lusb
come from an original libusb-0.1, or from a wrapper (or from an
OS-supplied API-compatible rewrite, as in FreeBSD).  The libusb 1.0
file and function names have been deliberately chosen to be different,
so there's no confusion.  (Besides, avrdude already starts detecting
libusb 1.0, but by now, it's only used for USBasp.)
cheers, J"org               .-.-.   --... ...--   -.. .  DL8DTL

http://www.sax.de/~joerg/                        NIC: JW11-RIPE
Never trust an operating system you don't have sources for. ;-)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]