[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Axiom-developer] RE: gcl-2.6.8pre on MAC OSX 10.2

From: Camm Maguire
Subject: Re: [Axiom-developer] RE: gcl-2.6.8pre on MAC OSX 10.2
Date: 02 Nov 2006 09:22:09 -0500
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.2


"Page, Bill" <address@hidden> writes:

> On Wednesday, November 01, 2006 8:18 PM Humberto Ortiz-Zuazaga wrote:
> > ... 
> > On PowerPC, make fails:
> > 
> > gcc  -o raw_pre_gcl  \
> > -L.    -lpre_gcl `echo -lSM -lICE  -L/usr/X11R6/lib -lXmu -lXt -lXext
> > -lXaw -lX11    -lm  -lreadline -lncurses | sed -e 's/-lncurses/ /'`
> > -lintl -lc -lgclp
> > /usr/bin/ld: can't locate file for: -lintl
> > collect2: ld returned 1 exit status
> > 
> > Fink installed a version of libintl from gettext-dev 0.10.40, so I've
> > added a "-L/sw/lib" and am retrying the build now.
> >
> Here is a recipe that seems to work for me and avoids reference
> to fink or other non-gcl related libraries:
>  $ export
> LIBRARY_PATH=/home/users/b/bi/billpage/osx/new/gcl-2.6.8pre/binutils/int
> l
>  $ make clean
>  $ ./configure --prefix=/usr/local --enable-locbfd --disable-statsysbfd
>  $ make
>  $ make install

locbfd should be the default on macosx, as we have Aurelien's specific
mods for .o file loading.  Extending this default to the intel should
resolve the -lintl 'out of the box'.  This said, I'd be quite
(pleasantly) surprised if Aurelien's code works as is on intel.  This
should be tried first -- if you can compile and load a simple file,
all is well.  Otherwise, the brain-dead default entry-level loading
option is --disable-statsysbfd --enable-dlopen.  This is limited in
that compiler::link instead of save-system must be used to save
images, and that no more than 1024 loads are supported on most
machines (as each requires an open file descriptor).

BTW, out of town till Sunday.

Take care,

> I have a new batch of Axiom cooking with this version of gcl.
> Note: It seems to be necessary to specify the --endable-locfd option
> to ensure that the bfd internal to gcl is configured with internal
> gettext.
> > On Intel, configure of gmp fails, as it can't figure out the machine
> > type. I have gmp 4.2.1 installed with fink, but I don't think I can
> > build gcl with that version of gmp.
> > 
> Too bad. :-( There are some options that affect gcl's use of gmp.
> See ./configure --help  You might try:
>   --disable-dynsysgmp
> I have also Cc: Camm Maquire, the primary GCL developer who might
> have some other suggestions for your Mac Intel platform.
> Thanks.
> Regards,
> Bill Page.

Camm Maguire                                            address@hidden
"The earth is but one country, and mankind its citizens."  --  Baha'u'llah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]