[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] arch: new program

From: Paul Eggert
Subject: Re: [PATCH] arch: new program
Date: Wed, 13 Jun 2007 08:19:22 -0700
User-agent: Gnus/5.110006 (No Gnus v0.6) Emacs/21.4 (gnu/linux)

Jim Meyering <address@hidden> writes:

> The option syntax is awkward due to autoconf's pseudo-requirement
> that such options look like --enable-REMAINDER_OF_NAME=VAL .
> I'd welcome a better name.

How about --enable-program-FOO and --disable-program-BAR, with the
default being close to what it is now (i.e., enable everything but
programs that won't build, and don't enable 'su' and 'arch')?  This
use of --enable* and --disable* fits better into common practice than
--enable-no- does.  It might be harder to arrange this on the autoconf
side, admittedly,...

reply via email to

[Prev in Thread] Current Thread [Next in Thread]