[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] arch: new program

From: Jim Meyering
Subject: Re: [PATCH] arch: new program
Date: Wed, 13 Jun 2007 17:28:41 +0200

Paul Eggert <address@hidden> wrote:

> Jim Meyering <address@hidden> writes:
>> The option syntax is awkward due to autoconf's pseudo-requirement
>> that such options look like --enable-REMAINDER_OF_NAME=VAL .
>> I'd welcome a better name.
> How about --enable-program-FOO and --disable-program-BAR, with the
> default being close to what it is now (i.e., enable everything but
> programs that won't build, and don't enable 'su' and 'arch')?  This
> use of --enable* and --disable* fits better into common practice than
> --enable-no- does.  It might be harder to arrange this on the autoconf
> side, admittedly,...

I could go either way on this.
I chose --enable-DO_OR_NOT_INSTALL=VAR so that one could add or
remove more than one program name with a single option, e.g.,


Another point is documenting the options in --help output:
With just two program-agnostic option names, the --help description
can work for other projects, too.  But I suppose I could work around

But maybe it's not worth the option-name ugliness.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]