bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Emacs21 display bug in text mode: "flashing window"


From: Gerd Moellmann
Subject: Re: Emacs21 display bug in text mode: "flashing window"
Date: 23 Oct 2001 14:15:21 +0200
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.1.50

Dast <address@hidden> writes:

> Please write in English, because the Emacs maintainers do not have
> translators to read other languages for them.
> 
> Your bug report will be posted to the address@hidden mailing
> list,
> and to the gnu.emacs.bug news group.
> 
> In GNU Emacs 21.1.1 (i686-pc-linux-gnu, X toolkit)
>  of 2001-10-22 on dracula
> configured using `configure  --prefix=/home/dast/newemacs21'
> Important settings:
>   value of $LC_ALL: nil
>   value of $LC_COLLATE: nil
>   value of $LC_CTYPE: nil
>   value of $LC_MESSAGES: nil
>   value of $LC_MONETARY: nil
>   value of $LC_NUMERIC: nil
>   value of $LC_TIME: nil
>   value of $LANG: C
>   locale-coding-system: nil
>   default-enable-multibyte-characters: t
> 
> System:
> Debian 2.2r3 (potato)
> Linux dracula 2.2.19 #1 Wed Aug 29 15:42:34 CDT 2001 i686 unknown
> 
> ldd emacs:
>         libXaw.so.6 => /usr/X11R6/lib/libXaw.so.6 (0x40014000)
>         libXmu.so.6 => /usr/X11R6/lib/libXmu.so.6 (0x4004d000)
>         libXt.so.6 => /usr/X11R6/lib/libXt.so.6 (0x4005f000)
>         libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0x400a7000)
>         libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0x400b0000)
>         libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x400c6000)
>         libtiff.so.3 => /usr/lib/libtiff.so.3 (0x400d6000)
>         libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0x40119000)
>         libpng.so.2 => /usr/lib/libpng.so.2 (0x40139000)
>         libz.so.1 => /usr/lib/libz.so.1 (0x40160000)
>         libm.so.6 => /lib/libm.so.6 (0x4016f000)
>         libXpm.so.4 => /usr/X11R6/lib/libXpm.so.4 (0x4018c000)
>         libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x4019a000)
>         libncurses.so.5 => /lib/libncurses.so.5 (0x4023c000)
>         libc.so.6 => /lib/libc.so.6 (0x4027a000)
>         /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
> 
> Please describe exactly what actions triggered the bug
> and the precise symptoms of the bug:
> 
> Start emacs by:
> emacs -nw --no-init
> 
> Then do the following:
> Split the window vertically: C-x 2 (split-window-vertically)
> Split the window horizontally: C-x 3 (split-window-horizontally)
> Enlarge the window: C-x ^ (enlarge-window)
> 
> The window setup should look something like:
> 
> +--------+--------+
> |c       |        |
> |   1    |   2    |
> +--------+--------+
> |                 |
> |        3        |
> +-----------------+
> 
> c indicates the position of the cursor, numbers indicate which window
> I am referring to.
> 
> After these three actions, window 2 "flashes" with every key I type.
> Usually it alternates between showing the contents of window 2 missing
> the mode line and showing the mode line of window2 but not the
> contents.  Sometimes (although I couldn't reproduce it, window 2
> disappears all together (no content and no mode line).  I realize this
> probably isn't very clear, so I set up a page of screenshots and
> description of keystroke sequences at:
> http://www2.msstate.edu/~cfy1/emacs/bug/
> 
> I also get this behavior with GNU Emacs 21.0.105.2
> (i386-debian-linux-gnu, X toolkit) on the same system, and with GNU
> Emacs 21.0.104.1 (sparc-sun-solaris2.6, X toolkit) on our school's sun
> box.
> 
> This behavior only happens in text mode.  I have verified it on my
> potato box in Eterm, in a stock xterm, and on the console
> (TERM=linux).

Pretty strange.  I don't see any problem here (FreeBSD 4.4).

Rob, can you reproduce this on Debian?

Do other people see it on other systems?



reply via email to

[Prev in Thread] Current Thread [Next in Thread]