[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: emacs-19.34 segfauls when built with Xfree 4.3.0 (glibc 2.3.x,gcc 3

From: Hin-Tak Leung
Subject: Re: emacs-19.34 segfauls when built with Xfree 4.3.0 (glibc 2.3.x,gcc 3.2)
Date: Thu, 15 May 2003 19:27:11 +0100
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

Richard Stallman wrote:
>     As it turns out, the solution (adding '-z nocombreloc' to LDFLAGS)
>     fixes problem with building current version of emacs as well.
> That is very strange.  The current version (21.3) contains code to use
> those options automatically--see src/s/gnu-linux.h.  Can you debug why
> this automatic mechanism failed to work for you?

I have to apologise for jumping to conclusion on this. I saw the other
bug report against CVS with an almost identical set up (very up-to-date
system) and same symtome, (segfault in X, works alright in -nw, dies
in XtInitializeWidgetClass ()), but have not verified it being the
underlying cause on current CVS myelf. I will try to either confirm or
correct that when I get round to it.

On the other hand, there was a somewhat curious bahavior with 19.34.
   LDFLAGS=... ./configure
breaks, but
    export LDFLAGS=...
works. I know they are different and there is no reason why one should
work the same as the other. Nonetheless, mentioning this might be
a useful piece of info to somebody.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]