bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#26589: Can't built Emacs from source (both master and 25.1 from tarb


From: Göktuğ Kayaalp
Subject: bug#26589: Can't built Emacs from source (both master and 25.1 from tarball fail)
Date: Sat, 22 Apr 2017 19:10:55 +0300
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.0.50 (gnu/linux)

On 2017-04-21 20:33 +03, Eli Zaretskii <address@hidden> wrote:
>> Date: Fri, 21 Apr 2017 08:20:47 -0400
>> From: Cadadr <address@hidden>
>> Cc: "address@hidden" <address@hidden>
>> 
>> I'm unable to build Emacs on my Xubuntu 16.10 machine from various
>> versions. Not having a built Emacs
>> handy, I have to send this bug report from a webmail client, so
>> please excuse formatting issues and not using
>> M-x report-emacs-bug.
>> 
>> - The 25.1 tarball
>> 
>> My build configuration
>> 
>> ./configure \
>> --prefix=$HOME/local \
>> --with-x-toolkit=gtk3 \
>> --with-modules \
>> --with-file-notification=yes
>
> Try running configure with REL_ALLOC=no.

I've had to switch linux distros on my workstation (Xubuntu->Fedora),
and now the build completes perfectly, without errors.  Not having
access to a Xubuntu installation, I can't reproduce or further debug
this issue, I'm sorry.

But both OS's had GCC 6 on them, and maybe what caused the failure on
Xubuntu was a certain configuration of the compiler on that platform.
Again, I can't test the configuration variable on that system, please
excuse me.  But on Fedora with GCC 6.3.1 and without REL_ALLOC=no, Emacs
does compile.

I guess this bug report can be closed if there's nobody else that can
reproduce the problem.  Again, sorry for the botherment.

-gk.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]