[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug-gnu-libiconv] Problem when executing iconv on ARM

From: Hamid A. Toussi
Subject: [bug-gnu-libiconv] Problem when executing iconv on ARM
Date: Thu, 6 Oct 2011 11:41:39 +0330

Hi all,

I have crosscompiled libiconv to arm-linux and run it. When i try to
convert some input file that includes Farsi characters using
bin/iconv, the program always exits with error "fa.txt:1:0: cannot
convert", no matter what parameters I run iconv with (I tried
different options for -f and -t, even -f char and -t char does not
work). This is due to EILSEQ conversion error as I understand.

Note that everything is working right when I compile and run iconv on
a x86 GNU/Linux computer (same file, same options) but the problem
occurs when I run iconv on our ARM board.

I would be thankful to receive your suggestions and comments.


Hamid A. Toussi

reply via email to

[Prev in Thread] Current Thread [Next in Thread]