[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: still no luck with grub

From: James Courtier-Dutton
Subject: Re: still no luck with grub
Date: Thu, 22 Jan 2004 19:32:03 +0000
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b) Gecko/20031208 Thunderbird/0.4

Disable INT13 BIOS extentions in the Adaptec BIOS.
CTRL-A while booting.

The Adaptec card has a bug in it's firmware, and changing this setting causes grub to use different calls to load the system. If you Adaptec card has a flash rom chip, then upgrade to the latest Adaptec firmware.


Daniel Senderowicz wrote:
Hi James,

Since I first submitted my problem, I did a few changes in my
hardware. Firstly I will answer your question: the SCSI adapter
is an Adaptec AIC-7880. I also modified some settings in the
bios, by not allowing it to assign the IRQs. And mainly I changed
the video card from the AccelGraphics AccelEclipse I to a STB
Velocity 3D - Virge VX and added a sound card Turtle Beach
(Vortex I) after disabling in the BIOS the built-in audio system.

As I see the problem now, when the system reboots it comes up with
the "grub>" prompt. Grub commands seem to work fine, but it does
not automatically boot the corresponding kernel. But when I boot
from the floppy the system is now stable, unlike it was before with
the other video card. I will appreciate any guidance for this



Daniel Senderowicz wrote:

Hi Norman,

If this is similar to the HP Dual CPU systems then you probably need to check the BIOS and the SCSI drive settings. I had an (A500 I think) a dual HP workstation at work that refused to boot grub and later got it to function by changing the SCSI drive from 'autoconfigured' to a specific id and then setting the BIOS appropriately.

This whole things confuse me a lot. First of all I don't know what
the bios (or the scsi adaptor) calls the only hard drive I have.
GRUB finds everything below (hd1,0). When I get into the scsi
configuration menu I read as the disk to be id=0, which I assume
comes from the disk not having any jumper (?). I followed your
advice and changed the id to 1, but no avail. I only see 3 options
for playing with scsi issues in the BIOS configuration menu, and
it pertains to use it as boot device and enabling/disabling

One could guess it is technically the onboard SCSI trying to autoconfigure in conjunction with the BIOS, but they both affect each other and the drive ordering as far as GRUB is concerned.

It appears that when I installed grub, it properly wrote in the
MBR, otherwise it wouldn't be giving me the message "grub hard disk
error". In fact I dumped the contents of the MBR using "dd" and it
looks like stage1. I read somewhere that this message is related
to proper/improper reading of the disk geometries, which would
indicate that is not related to the id of the device, or am I
missing something? I feel a bit frustrated now, ready to fork out
a few bucks on a IDE disk, or should I keep some hope?



Which SCSI controller? Model number ?


Bug-grub mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]