[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [bug-gv] problems with libXaw3D-1.6.1

From: Markus Steinborn
Subject: Re: [bug-gv] problems with libXaw3D-1.6.1
Date: Tue, 28 Feb 2012 21:24:30 +0100
User-agent: Mozilla/5.0 (X11; Linux i686; rv:10.0.2) Gecko/20120216 Firefox/10.0.2 SeaMonkey/2.7.2

Hi Orion,

Orion Poplawski schrieb:

I have no idea if this will compile on EL6/5, but you could try:


Thanks, that compiled well for me on CentOS 5.7. I ran into the same problems you have.

But I got the reaason: "/usr/include/X11/Xaw3d/Xaw3dP.h" has been created in a wrong way:

It has to contain #define's (as it did on Xaw3d-1.5E):

--- cut here (from Xaw3d-1.5E) ---
--- cut here ---

The other headers #ifdef for them.

Patching "/usr/include/X11/Xaw3d/Xaw3dP.h" (as root) by just inserting these #define's and then recompiling GNU gv (configure && make) gives me a working GNU gv.

So I suppose it's a bug within libXaw3d-1.6.1.

Greetings from Germany

Markus Steinborn
GNU gv maintainer

reply via email to

[Prev in Thread] Current Thread [Next in Thread]