[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-moe] keycodes are entered into buffer

From: Benno Schulenberg
Subject: Re: [Bug-moe] keycodes are entered into buffer
Date: Tue, 06 Sep 2016 22:11:27 +0200

On Tue, Sep 6, 2016, at 18:37, Antonio Diaz Diaz wrote:
> Benno Schulenberg wrote:
> > I've tried out moe.  (It required installing lzip in order to decompress
> > the tarball, which is inconvenient.  You might consider offering at least
> > also a gzipped tarball.)
> Was it very inconvenient? No, really, I am interested in the answer. :-)

Majorly inconvenient.  At first I let it be, when xz couldn't decrompress
the file.  But I wanted to investigate the competitors of nano, so I tried
again, and finally figured out that I needed lzip for decompression.  Bwuh.

> I'm trying to increase awareness of lzip because gzip is in the (slow) 
> process of being replaced by some compressor using a variant of the LZMA 
> "algorithm". The problem is that the other 3 formats (7z, lzma-alone and 
> xz) have problems, defects or both.

What problems or defects does xz have?

> So I would like to reach an optimal balance between inconvenience and 
> awareness.

Very, very few people will be interested in moe, so showcasing lzip there
has just about zero effect.  The major effect it has is to stop people from
trying moe, because it's zipped in a by default inaccessible format.

If you want to showcase lzip, you should get a major package like grep
or coreutils to adopt it.

> When you start moe, you can see at the right of the status line "F1 for 
> help". ^H is just an alias for F1.

Oh, ^H was quite intuitive.  Much more than F1.  Besides, F1 in my
terminal emulator calls up the manual of that Terminal.  :|

> > But now why I write.  One of the first things I tried in moe was:
> > Shift+Left in order to select a bit of text.  "Key code 393(0x189)
> > ignored".  Okay.  Same result for Shift+Right.  But when I type
> > Shift+Up or Shift+Down, the strings "1;2A" and "1;2B" are entered
> > into the buffer.  The same for any Ctrl+Arrow keystroke.  This is
> > unexpected and undesirable.
> In what environment are you trying moe?

In a Gnome Terminal.

> In my VGA text console, Shift+<arrow> and Ctrl+<arrow> both work just as 
> <arrow> alone.

Ah, yes, a Linux console is completely handicapped: for the Arrow
keys it completely ignores the modifiers.

> In a Konsole terminal emulator:
>    Shift+Left and Shift+Right switch to previous/next console.
>    Shift+Up and Shift+Down scroll through the terminal history.
>    Ctrl+<arrow> works just as <arrow> alone.

Konsole is another deficient terminal.  I pray for its users that
those key combos can be reassigned.

> What ncurses library are you using?

Version 5.7 on the machine that I normally use.

> > And then a question: how do I jump from word to word in moe?
> > (In many editors one can use Ctrl+Left/Right for that.)
> Moe does not currently provide a command for this, but I'll investigate 
> the possibility of adding it. Could you tell me some editors that do 
> this, and describe the behavior (on what character of the word the 
> cursor lands, for example). Thanks.

Just about all editors do this.  Emacs, Vim, Pico, nano, Gedit, Geany.
And all word processors that I know (LibreOffice Writer, for example).
(Not on a Linux console, of course, but on a Gnome Terminal yes.)
The only one that doesn't do it is Joe.

A Ctrl+Left always lands on the first character of a word.  The behavior
for a Ctrl+Right differs: Vim, Pico, nano, dex, Minimum Profit and Writer
all go to the first character of the next word; Emacs, Gedit and Geany
land right after the last character of the current word.


http://www.fastmail.com - Choose from over 50 domains or use your own

reply via email to

[Prev in Thread] Current Thread [Next in Thread]