[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Chicken-users] Eggology

From: Benedikt Rosenau
Subject: [Chicken-users] Eggology
Date: Tue, 21 Aug 2007 19:20:30 +0200
User-agent: Mutt/1.4i


Today, I ran an upgrade because 'chicken-meta-setup check'
showed new eggs. However after installing the new tinyclos,
misc-extn, and lookup-table eggs, a new check with
chicken-meta-setup failed because that crashes.

Further, chicken-setup on logging fails because it requires
uri, and setup on tool fails because that requires array-lib.
On both occasions, these eggs are said to not exist, e.g.:

Error: Broken dependencies: extension does not exist: array-lib

I am looking for a solution that does not mean installing all
eggs from scratch.

Anyway, I propose the following: please keep dependencies between
eggs small. Kon has a set of extensions called misc-extn, which is
fine, but an egg should not need more than one set of idiosyncratic
extensions.  Further, no mutual dependencies (A needs B, and B needs
A) should be created.  Dependencies by proxy are even worse. And
lastly, "core eggs" should use es few other eggs as possible. Eggs
that are compiled in unsafe mode or idiosyncratic should not appear
here at all.

Thanks to everyone who contributed and contributes,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]