[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Chicken-users] Bug in chicken-2.636

From: Zbigniew
Subject: Re: [Chicken-users] Bug in chicken-2.636
Date: Mon, 27 Aug 2007 12:03:56 -0500

Sorry if I wasn't more clear--

You can simply download the latest SVN snapshot (5752) now and compile
it with any compiler (including chicken-2.6).  You don't have to
install an intermediate compiler.

Also, in general it's not necessary to copy any configure (etc.) files
over; these are automatically generated when you run `sh`,
and this issue had nothing to do with the autotools or Makefiles.
Furthermore, revision 5361 builds with the old Chicken 2.6 compiler;
no need to download snapshot chicken-2.636 at all.

On 8/27/07, Benedikt Rosenau <address@hidden> wrote:
> Hello all,
> Thanks to Zbigniew, I got a newer version of Chicken to work.
> To spell it out in detail:
> Install chicken-2.6 from the webpage.
> Download the snapshot chicken-2.636.
> Go to a directory and execute the following:
> $ svn co -r 5361
> $ mv trunk trunk-old
> $ svn co
> Next, go to "trunk-old" and copy the following files from chicken-2.636:
> config.guess config.sub configure
> compile chicken.texi texinfo.tex.
> $ automake -a && aclocal && autoconf
> $ make CHICKEN=`which chicken`
> $ make install
> This should give you working version of chicken-2.634.
> Repeat the process above (starting with "Next,") in the directory
> "trunk". This should give you a working version chicken-2.638.
>    Benedikt
> _______________________________________________
> Chicken-users mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]