[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Denemo-devel] Does Denemo open third-party lilypond files?

From: Richard Shann
Subject: Re: [Denemo-devel] Does Denemo open third-party lilypond files?
Date: Tue, 17 Feb 2009 08:38:32 +0000

On Mon, 2009-02-16 at 21:40 -0800, Ken Klaser wrote:
> If I've asked this question in the wrong place, my apologies.  If I've
> asked in the right place, thanks in advance for your consideration!
> One question: Should Denemo 0.8.2, installed from tar.gz (not a .deb
> file), running on Debian GNU/Linux 5.0 "Lenny", open an already made
> Lilypond file such as those published by
It often does not succeed on .ly files from elsewhere. If there are a
lot of notes it might be worth cutting and pasting them into a file that
denemo can read.
Denemo does actually manage to open the example you give, but as it
doesn't understand the \relative command the notes are generally in the
wrong octave. 
The rhythm is all there though, so if you have a midi keyboard you could
play the notes in at full speed (using the Advance On Edit mode) and the
right pitches would be put onto the rhythms.


> Such as this this lilypond file:
> Not a question, just some context: Neither the Synaptic-installed Denemo
> 0.7.7 or the later compiled 0.8.2 seems to open those files.
> I'm wondering if my system or installation (I'm a Linux noob), or
> downloaded file has a problem such as .ly version compatibility or
> corruption (it's saved from the browser), or if Denemo doesn't yet offer
> that particular functionality of opening third party lilypond files.  
> _______________________________________________
> Denemo-devel mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]