[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Denemo-devel] Re: denemo and GPLv3

From: Nils Gey
Subject: Re: [Denemo-devel] Re: denemo and GPLv3
Date: Sat, 8 May 2010 20:48:41 +0200

I think the quickest way to get this solved, whatever the solution is, is to 
get approval by all copyright holders or at least the ones we can reach.

For all cases:

- Was your part of Denemo GPL2+ or just GPL2?
- Do you agree on changing the license to "GPL3 or any later version"? 
- What about future cases? Do you still care about Denemo and your parts? Do 
you want to give the current maintainer, Richard Shann, the authorisation to 
decide for you if there are any further license change in the future?

Then we have to check if there are any dependencies which are only GPL without 
"later versions" and ask them to upgrade, too, or grant Denemo a special 
license, if that is legaly possible.

Finally we have to agree if we want the GPLv3 or not.


On Wed, 05 May 2010 14:49:36 +0100
Richard Shann <address@hidden> wrote:

> On Wed, 2010-01-06 at 23:30 +0000, Karl Berry wrote:
> > Hi everyone -- did we discuss upgrading denemo to GPLv3-or-later?  I
> > belatedly noticed the new release was still GPLv2, it seemed.  Any
> > problems with switching next time?
> I posted this email on to denemo-devel, but apart from some emails about
> whether GPLv3 is a good thing nothing has happened. Looking around the
> denemo code, it looks like what you would do is replace the file COPYING
> with a new one (I expect there is a correct place to get it from...).
> If that is right and no-one objects I will do that.
> Richard
> _______________________________________________
> Denemo-devel mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]