[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Re: mblock make failure under Cygwin

From: Eric Blossom
Subject: Re: [Discuss-gnuradio] Re: mblock make failure under Cygwin
Date: Tue, 27 May 2008 12:20:03 -0700
User-agent: Mutt/1.5.17 (2007-11-01)

On Tue, May 27, 2008 at 12:31:46PM -0400, Don Ward wrote:
> Steven Clark wrote:
>> On Fri, May 23, 2008 at 4:51 PM, Steven Clark <address@hidden> 
>> wrote:
>>> I reinstalled gnuradio under cygwin from scratch, using the latest
>>> subversion trunk.
>>> Following http://gnuradio.org/trac/wiki/CygwinInstallMain, I
>>> built/installed a minimal gnuradio setup, and that worked fine.
>>> Then I tried to add a few extra parts of gnuradio (usrp, mblock, gpio,
>>> etc.) and ran into what looks like a linker problem involving
>>> inband/mblock code (possibly also involving boost?)
>>> build log & build error file are attached...any ideas/workarounds?
>> Bump in case my email got lost in the weekend shuffle. The first error
>> encountered is:
>> .libs/qa_inband_usrp_server.o: In function
>> `_ZN5boost6detail17sp_counted_impl_pI12qa_alloc_topE11get_deleterERKSt9type_info':
>> /usr/include/boost-1_33_1/boost/detail/sp_counted_impl.hpp:(.text+0x9b):
>> undefined reference to `mb_mblock::~mb_mblock()'
> It looks like you are missing a patch (attachment:"makefiles6975.patch, 
> listed on the Cywin wiki page) needed to include the mblock library in the 
> link of qa_inband_usrp_server.
> -- Don W.

Thanks Don.

FYI, we haven't applied this patch to the trunk because the real
problem is with libtool under cygwin.  The patch replicates
information (always a bad idea) that libtool already knows on all
other systems.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]