[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Important: New trunk dependency: GSL

From: Philip Balister
Subject: Re: [Discuss-gnuradio] Important: New trunk dependency: GSL
Date: Wed, 10 Sep 2008 15:40:56 -0400

On Wed, Sep 10, 2008 at 1:59 PM, Eric Blossom <address@hidden> wrote:
> I'll be adding the GNU Scientific Library (GSL) as a new dependency
> on the trunk.  GSL is a huge numerical library that's been under
> active development for more than 10 years:
>  http://www.gnu.org/software/gsl

I've been making progress getting GNU Radio trunk running on the OMAP3
and now you toss this my way. Fortunately, OpenEmbedded already knows
about gsl and it builds for the beagle.

But, I am still curious, what parts of GNU Radio use gsl?  Will it be
possible to deply GNU Radio apps that do not need it? Or will gsl
creep into the very core of GNU Radio?


> Fedora, Debian and Ubuntu all package it.
> Under Fedora the relevant packages are: gsl-devel gsl pygsl:
>  $ sudo yum install gsl-devel gsl pygsl
> I'm not exactly sure of the package names under Debian or Ubuntu.
> Could someone who knows please let us know and update the Debian and
> Ubuntu build pages on the wiki?  I'll update the Fedora page.
> gsl-1.11 is the latest, but it looks like gsl-1.10 is what's widely
> distributed.  1.10 should be fine.
> Thanks!
> Eric
> _______________________________________________
> Discuss-gnuradio mailing list
> address@hidden
> http://lists.gnu.org/mailman/listinfo/discuss-gnuradio

reply via email to

[Prev in Thread] Current Thread [Next in Thread]