[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] u2_flash_tool : Can not find the command

From: Andy_Long
Subject: Re: [Discuss-gnuradio] u2_flash_tool : Can not find the command
Date: Wed, 3 Mar 2010 08:14:48 -0800 (PST)

Johnathan, Thank you for your advice. 

I have run this command successful. But the usrp2 is still not working
properly. The problem is that only one LED light (F) is on after inserting
the 2Gb SD card (normal SD card produced by sandisk).

There are two previous advices for the same problem given Eric is: 

{1} http://old.nabble.com/Write-bin-to-SD-card-td21680697.html#a21720767 
((((((Yabo Li wrote: 
> Hi Eric, 
> Thanks very much for answering my questions. I tried a different SD card 
> (SanDisk), and now only one LED is on (LED F). Do you know what does 
> this mean? 

 One LED means that the FPGA was programmed, but not the firmware. 
Either you didn't put the firmware on the card, or the card is bad. 

Why don't you just use the SD card which came with the USRP?  It is 
known to work.  


Because the SD card sent with USRP2 was bad that this method is not suitable
to me. I also used another SD card by getting the same results and did not
see the error information when I wrote the firmware.  

Another solution is that 

(((((((((Remove all daughterboards and cables except the power supply. Does
it do the same thing, or do you get two leds?

I still only get one LED.

> Also, if the SD card slot is stiff and/or
> sticking, make sure that when you push the card in that it clicks and
> slides
> back a bit.

Yep, the SD card slot makes the clicking sound when I push the card in and
the card seems to be in there properly.

> If that still doesn't work, please call the office so we can
> discuss it further.

Will do. Thanks!

I have followed this steps, but still one f LED is on. However, another
USRP2 shows the same results that I think the platform should be ok.

The code I used to write the firmware and FPGA was listed as below. After
each step, I used u2_flash_tool + v to check if it works fine. There is no
any error shown on the terminal.

address@hidden:~$ cd /home/shi/Desktop/
address@hidden:~/Desktop$ df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/sda5             14318528   3388676  10202512  25% /
tmpfs                   995828         0    995828   0% /lib/init/rw
varrun                  995828        92    995736   1% /var/run
varlock                 995828         0    995828   0% /var/lock
udev                    995828       192    995636   1% /dev
tmpfs                   995828       460    995368   1% /dev/shm
lrm                     995828      2392    993436   1%
/dev/mmcblk0p1         1925464         4   1925460   1% /media/disk-1
address@hidden:~/Desktop$ sudo ./u2_flash_tool --dev=/dev/mmcblk0p1 -t s/w
txrx.bin -w
[sudo] password for shi: 
address@hidden:~/Desktop$ sudo ./u2_flash_tool --dev=/dev/mmcblk0p1 -t s/w
txrx.bin -v
address@hidden:~/Desktop$ sudo ./u2_flash_tool --dev=/dev/mmcblk0p1 -t fpga
u2_rev3.bin -w
address@hidden:~/Desktop$ sudo ./u2_flash_tool --dev=/dev/mmcblk0p1 -t fpga
u2_rev3.bin -v
address@hidden:~/Desktop$ find_usrps
No USRP2 found.

Another strange thing is that after inserting the SD card into the USRP2, it
can not recognized by Ubuntu 9.04 anymore. Thus every time I have to format
it in windows before I am using u2_flash_tool to rewrite the firmware and
FPGA again. (I have tried to format it as FAT,FAT32,NFTS which makes no
difference. Because I guess the u2_flash_tool will remove the file system
created by windows). 

I am wandering if I did anything wrong when I am using the u2_flash_tool to
burn the firmware? Or maybe I have to try to use another brand SD card
rather than Sandisk? Or Do I need to do something more with SD card before
using u2_flash_tool? 

Thank you.


View this message in context: 
Sent from the GnuRadio mailing list archive at Nabble.com.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]