[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] segmentation fault (core dump) -- help needed

From: Thomas H Kim
Subject: [Discuss-gnuradio] segmentation fault (core dump) -- help needed
Date: Mon, 8 Nov 2010 07:42:25 -0500

Hi all,

I'm a newbie in gnu software radio (and in python, and in linux) and got stuck on this segmentation fault issue.
I am trying to setup GNU software radio on a machine (HP workstation xw8600 with dual intel Xeon processor).
I installed Fedora Core 14 and installed all needed dependencies using YUM as shown below.

yum groupinstall "Engineering and Scientific" "Development Tools"
yum install fftw-devel cppunit-devel wxPython-devel libusb-devel guile boost-devel alsa-lib-devel numpy gsl-devel python-devel pygsl python-cheetah python-lxml
yum install sdcc

yum install gnuradio
yum install gnuradio-examples
yum install usrp

The installation went ok without any issue.
However, when I tried dial tone example at "/usr/share/gnuradio/examples/audio/dial_tone.py", it said nothing else but "segmentation fault(core dump)", and nothing happened. I tried other examples, but this segmentation fault error came up all the time. I found a couple of simple gnu radio examples from google and tried, but the same thing happened. I inserted print statement in the code to see where it failed and it failed in "my_top_block().run()" function.

I want to know why this problem occurs and how to solve it. Can anyone help me out? Any idea/suggestion will be welcomed.
I'm still studying GNU software radio blocks, but is there any way to narrow down which block (or which function) cause this segmentation fault?



reply via email to

[Prev in Thread] Current Thread [Next in Thread]