[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] SDCC 3.0.0?

From: Tom Rondeau
Subject: Re: [Discuss-gnuradio] SDCC 3.0.0?
Date: Mon, 22 Nov 2010 18:20:12 -0500

On Mon, Nov 22, 2010 at 5:19 PM, Josh Blum <address@hidden> wrote:
> On 11/22/2010 01:07 PM, Elvis Dowson wrote:
>> Hi Michael,
>> On Nov 23, 2010, at 1:02 AM, Michael Dickens wrote:
>>> MacPorts just upgraded SDCC from 2.9.0 to 3.0.0, which seems to have
>>> changed the install names of various of the executables including the one
>>> required by USRP: asx8051 ->  sdas8051.  I haven't verified that these
>>> executables work equivalently; I'll try to do that tonight.  Has anyone
>>> tried doing this version yet with GNU Radio? - MLD
>> Is SDCC really necessary to work with the UHD drivers on Mac OS X ?
> For UHD, binaries to all FPGA and firmware images are posted online. The
> library does not require anyone to build them to use a USRP device.
> Now, the gnuradio usrp driver does have this requirement. I might suggest
> that somebody take the sdcc requirement out of the driver and just check-in
> the built images (they have not changed in years).
> -Josh

In the meantime, you can remove the problem for any personal installs
people are having by commenting out line 51 in config/grc_usrp.m4.

Michael, let me know what you find about about the new names, please.

Josh, we should talk next week on the specifics about removing this
dependency. It might be appropriate to wait for the mythical GRAND
RESTRUCTURE that's been being kicked around.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]