[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] UHD Announcement - July 19th 2011

From: Nick Foster
Subject: Re: [Discuss-gnuradio] UHD Announcement - July 19th 2011
Date: Sat, 23 Jul 2011 11:13:43 -0700

On Sat, 2011-07-23 at 18:55 +0100, Nemanja Trecakov wrote:
> There are two more things I am not clear with.
> > > 
> > > I understand that the FPGA and firmware images have to be updated,
> i.e. the newest images downloaded and "flashed" on the SD card in case
> of USRP2.
> > > However, since the source code is new too, should I rebuild and
> reinstall the UHD from the new source?
> > > 
> > 
> > The host code and images must match. If you want to use the latest
> > images, you have to download and install the latest UHD host code as
> > well.
> http://code.ettus.com/redmine/ettus/projects/uhd/wiki#Source-code
> 1. Why must code and images match? If FPGA image is newer than the UHD
> code one have installed, according to my logic only things that are
> different would not work.

Because we tend to change all sorts of stuff under the hood between
releases. We try to keep things sane by using a FPGA "compatibility
number", and use that compatibility number to ensure you're using
compatible host code and FPGA images.

> 2. I want to adjust the FPGA image slightly.  I want to write some
> extra Verilog code and build it myself with Xilinx. However, since I
> change the image on the FPGA, and the installed UHD code has to match
> to the image, how can this work?

You can do whatever you want to the FPGA image, we're just saying you
should start with corresponding FPGA and UHD host code versions.


> Thank you in advance.
> Nemanja
> _______________________________________________
> Discuss-gnuradio mailing list
> address@hidden
> https://lists.gnu.org/mailman/listinfo/discuss-gnuradio

reply via email to

[Prev in Thread] Current Thread [Next in Thread]