[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Almost working

From: Marcus D. Leech
Subject: Re: [Discuss-gnuradio] Almost working
Date: Sun, 04 Sep 2011 17:07:32 -0400
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20110817 Fedora/3.1.12-1.fc14 Thunderbird/3.1.12

On 09/04/2011 04:57 PM, Greg Le Sage wrote:
The revised build-gnuradio.sh produced no errors on my Fedora 14 installation. It does handle the changes to the web site holding the FPGA and firmware, so I did not need to append /old to the web link in the script anymore. None of the errors from yesterday popped up at all. The GRC programs show the right icons now. When I try to run any of them, I receive the error

"Cannot import gnuradio. Are your PYTHONPATH and LD_LIBRARY_PATH set correctly?"

I read a bunch about this problem this morning and tried the following.

python -c "import sys; print sys.path"

All of the /python2.7/site-packages seem to be in there already, but I also did

export PYTHONPATH=$PYTHONPATH:/usr/local/lib/python2.7/site-packages

This did not add anything to PYTHONPATH when I examined it, so I think that is already set correctly.

Next I did

export LD_LIBRARY_PATH="/usr/local/lib:/usr/lib:$LD_LIBRARY_PATH"

These were the steps I found in previous discussions.

I still receive the same error message when I try to run any of the GRC programs.

When I do


the list does include /usr/local/lib and /usr/lib

I set up a custom script in /etc/profile.d with the following

export PYTHONPATH="/usr/local/lib/python2.7/site-packages"

export LD_LIBRARY_PATH="/usr/local/lib:/usr/lib"

I verified that these values were present using

echo ${PYTHONPATH} and


GRC still gives the same error, and more confusingly, my working installation on Ubuntu shows blank lines with the above echo commands.

It also seems to me that these path variables need to point to lots more places. I will keep reading.

Sorry for not being more familiar with Linux.

Can someone give me advice on addressing the error presented by GRC for Fedora 14?


You shouldn't need to do *anything* to LD_LIBRARY_PATH.

But on x86_64 systems, Fedora uses /usr/local/lib64/python2.7/site-packages

So, if you're on a x86_64 system on Fedora, you'll need to set your PYTHONPATH to point to /usr/local/lib64/python2.7/site-packages

Marcus Leech
Principal Investigator
Shirleys Bay Radio Astronomy Consortium

reply via email to

[Prev in Thread] Current Thread [Next in Thread]