[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GNUstep StartUp on a Mac Powerbook

From: Yves de Champlain
Subject: Re: GNUstep StartUp on a Mac Powerbook
Date: Sun, 27 Mar 2005 12:21:25 -0500

Le 05-03-26, à 22:44, Tabitha McNerney a écrit :

Hi Guys,

I am wending my way through GNUstep on my Mac Powerbook. It has OS X
10.3.8 and I have installed the developer tools XCode 1.5 with the
November 2004 XCode update to gcc.

I also have Darwin Ports installed on an external firewire drive (the
core installation directory is /Volumes/external/opt/local).


Running X works just fine when I run XDarwin by invoking xinit and I
get WindowMaker.

it is usually better to use startx

For GNUstep I have installed the required libraries such as for jpeg
and tiff via Darwin Ports so they end up in a location like this:


And I have added this PATH to my bash profile for my terminal shell login.

Yet, whenever I run ./InstallGNUstep (I have tried by selecting
options 1 (since I have sudo access) and 2 (I want to try installing
in my home directory), it doesn't matter because I get errors stating
that I don't have libtiff and libffc (but I really do -- these
libraries are in my Darwin Ports library and they are in my $PATH) so
what am I doing wrong?

You need to set some more environment variables

export CPPFLAGS=-I/Volumes/external/opt/local/include
export CFLAGS=-I/Volumes/external/opt/local/include
export LDFLAGS=-L/Volumes/external/opt/local/lib

Also can anyone tell me why I get this error? I have gcc 3.3:

$ gcc -v
Reading specs from /usr/libexec/gcc/darwin/ppc/3.3/specs
Thread model: posix
gcc version 3.3 20030304 (Apple Computer, Inc. build 1671)

E281 Error
I don't seem to be able to use your Objective-C compiler to produce
working binaries!  Please check your Objective-C compiler installation.
For gcc-3.0.x make sure that your compiler's libgcc_s and libobjc
can be found by the dynamic linker - usually that requires you to add
the directory given by gcc -print-file-name=libobjc.so to your
LD_LIBRARY_PATH or /etc/ld.so.conf.
Please refer to your compiler installation instructions for more help.

Apple's gcc is not a good option, you need FSF gcc.  3.3.5 works well
This error is probably the result of gcc called with -lgcc_s
which Apple's gcc does not have.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]