discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: gnustep on macos x panther


From: Enrico Sersale
Subject: Re: gnustep on macos x panther
Date: Sat, 16 Apr 2005 02:26:28 +0300

On 2005-04-15 23:42:58 +0300 Secret Guy <address@hidden> wrote:

I've installed or am trying to install gnustep. I used instructions I
read here:

http://www.zathras.de/angelweb/x2004-10-30.htm

However, I was unable to install libffi. I tried gcc-3.3.2, 3.3.5,
3.4.0, 3.4.1, 3.4.2 and 3.4.3, and tried pyobjc/libffi-src with some
of those and all either didn't support objc or failed to build ffi.

Though the README.Darwin in gnustep-make-1.10.0 says libffi is
required, it also later says what to do if "you decided not to install
libffi". So, I took that path.

I then installed windowmaker gworkspace and ink. However, the dialogs
and windows that show the file system in ink and fileviewer in
gworkspace don't show some directories (!!?), for example it doesn't
show /usr or /opt. This is problematic because I want to set the
editor to use in gworkspace, but I can't browse to where the
application wrappers are.

Are you sure that there isn't a ".hidden" file in "/"?

I tried changing ownership of /opt as a test and it still doesn't show up.

Also, Ink's dialog shows only directories, no files, so I can't select
a file to edit.

So, do you have any ideas about what that problem might be? Also, do I
need l ibffi? If so, which gcc should I use?





reply via email to

[Prev in Thread] Current Thread [Next in Thread]