[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Successful build of emacs-unicode-2 under Windows with MinGW

From: Cheng Gao
Subject: Re: Successful build of emacs-unicode-2 under Windows with MinGW
Date: Thu, 23 Sep 2004 17:51:31 +0800
User-agent: Gnus/5.110003 (No Gnus v0.3) Emacs/21.3.50 (windows-nt)

| Lots of us are testing the trunk.  I think it is important
| to have some people regularly using the emacs-unicode-2 branch,
| while most test the trunk.
| So if you're regularly using the emacs-unicode-2 branch,
| please speak up.

I think this branch especially interests users from non-latin language 
like me. For example, with Chinese-GBK and Chinese-GB18030 supported in
emacs-unicode-2, it's very happy to use Gnus to view any Chinese
message. While with Emacs trunk, some messages can not be viewed
properly with GB2312. This is why I am so interested in this branch.

So far my adventure is fairly good, though I expect there will be many
bugs. (In fact I have found some).

Now the most painful thing is with getting source. 
Savannah CVS is really slow for this branch. I think it takes forever
for me to update it. At the same time, trunk update is fairly fast.
And I have luckily gotten Miles' arch source for only once. After that,
I have tried several times to update with no joy.

Now I am very curious for one thing:

Is there any big date/time processing related changes in unicode-2

At least under MinGW version, evaluating 

(format-time-string "%Y-%m-%d" emacs-build-time)

generates an empty string as "        " (8 spaces).

While value of `emacs-build-time is (16722 29008 93000).

I have compared src/editfns.c of trunk and unicode-2 branch and found no
difference. I think the changes are in other place(s). 

And if I run Gnus in Emacs 22, then exit (with newsrc.eld saved), then I
use Emacs trunk (21.3.50) to run Gnus, it generates an error as "Invalid
Date:". My investigation shows that in newsrc.eld,
`gnus-newsrc-last-checked-date is set as a empty string by Emacs 22. 

So I have to remove (setq gnus-newsrc-last-checked-date ...) line
manually from .newsrc.eld, and Gnus can run from Emacs trunk.

But then without this line, Gnus can not run from Emacs 22. It shows the
same error as "Invalid Date:".

Then I have to run Gnus in Emacs trunk, and exit, thus a valid (setq
 gnus-newsrc-last-checked-date ...) line is generated, and then Gnus can
 be run from Emacs 22.

This test is with MinGW build with source got two weeks ago. Maybe this
has been fixed, but owing to inaccessibility of cvs/arch source, I can
not test with the latest code.

My preliminary impression is that this problem may be platform-specific.
In my home computer with Gentoo GNU/Linux with latet code, seems above
mentioned two problems dont exist. Tonight I'll make check and confirm this.

Sincerely yours, 



reply via email to

[Prev in Thread] Current Thread [Next in Thread]