[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem with viper-replace-char and Swedish characters on w32

From: Lennart Borgman
Subject: Re: Problem with viper-replace-char and Swedish characters on w32
Date: Wed, 29 Mar 2006 21:37:43 +0200
User-agent: Thunderbird 1.5 (Windows/20051201)

Lennart Borgman wrote:
This is for Emacs on w32. There is a problem in viper when replacing a character (using the "r" command - `viper-repace-char') with a Swedish character. (For example รถ which is an o with two dots above.)

I am using Swedish keyboard layout. Under w2k this is set in Control Panel - Regional Settings - Input Locales - Keyboard Layout. I have tested two different locales, which gives different results below. The locales are found under ... - Regional Settings - General - Your Locale.

Since no one has answered I will try to restate the question in a more general and simple manner: The user is prompted for a single character and this character should then be inserted in the buffer. The question is how this should be done. The current code in viper does AFAICS something similar to

   (insert (read-char "char: "))

This gives incorrect display of character if it is a Swedish character (like o with two dots above) under the conditions I explained before (Swedish keyboard, Local English). The code below gives the desired result:

   (let ((last-command-char (read-char "c:"))) (self-insert-command 1))

Is this the correct way to do it?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]