[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Pretest

From: Chong Yidong
Subject: Re: Pretest
Date: Mon, 30 Oct 2006 17:04:50 -0500
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.0.90 (gnu/linux)

Eli Zaretskii <address@hidden> writes:

> Something very strange is going on here: I unpacked the pretest
> tarball in a different directory, and it builds there even with the
> original configure script.
> So I think the configure script is not the problem here.  I will try
> to look deeper when I have time; in the meantime, let's continue the
> pretest as if this problem never happened.

I wonder if this is related to the problem reported by Martin Ebourne
<address@hidden> in the thread "Small fix to configure.in in
CVS".  He said:

> > The problem I had was that I was building to a prefix directory that 
> > included the word 'linux'. The emacs configure was preprocessing the 
> > Makefile through the C preprocessor, and this was substituting 
> > 'linux' to 1, thus making all the paths invalid.

I haven't checked in the patch he supplied yet, since I was trying to
figure out whether the problem really exists.  However, if the patch
fixes the problem for you, I guess we should check it in.

--- emacs/configure.in~ 2006-09-28 06:47:26.000000000 +0100
+++ emacs/configure.in  2006-10-25 13:50:29.000000000 +0100
@@ -3230,7 +3230,7 @@
 # the C preprocessor to some helpful value like 1, or maybe the empty
 # string.  Needless to say consequent macro substitutions are less
 # than conducive to the makefile finding the correct directory.
-[undefs="`echo $top_srcdir $configuration $canonical |
+[undefs="`echo $ac_top_srcdir $configuration $canonical |
 sed -e 's/[^a-zA-Z0-9_]/ /g' -e 's/^/ /' -e 's/  *$//' \
     -e 's/  */ -U/g' -e 's/-U[0-9][^ ]*//g' \

reply via email to

[Prev in Thread] Current Thread [Next in Thread]