[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: display-buffer-alist simplifications

From: Juri Linkov
Subject: Re: display-buffer-alist simplifications
Date: Wed, 27 Jul 2011 23:27:11 +0300
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.0.50 (x86_64-pc-linux-gnu)

>   (display-buffer buf
>     '((reuse-window :buffer same :window other)
>       (pop-up-window :root lru :side right :min-width 10)))
> This syntax is (IMO) much more readable.  It is easy to guess what every
> element means---one problem I have with the current design is that I
> have to delve into the docstring to work out what the different elements
> and special tags mean.  And it has the advantage of similarity with
> other facilities in Emacs, like defface specs.

In defface specs parameters like `min-width 10' are specified in the
condition part of `defface' like `min-colors 88' as a list.
For non-conditional parameters I agree that the plist syntax is better.
And defface spec merges plist attributes from inherited faces.

I also want to note that tags like `reuse-window' and `pop-up-window'
are redundant in plists.  Their meaning can be expressed as plists like
`:window same', `:window other', `:buffer same'.  This would bring
them closer to the syntax of defface specs that is proven to be flexible
and easy to configure.

> If so, it might be good to revert everything and postphone
> these changes to 24.2.

It would be very sad to revert and move development backward.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]