[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Orgmode] Re: storing link doesn't work from Gnus

From: Carsten Dominik
Subject: Re: [Orgmode] Re: storing link doesn't work from Gnus
Date: Tue, 28 Nov 2006 07:55:32 +0100

On Nov 27, 2006, at 21:24, Bernard Adrian wrote:

Carsten Dominik <address@hidden> a écrit :

Could someone make a backtrace of this error, with loading uncompiled
versions of gnus-sum.el and org.el?  The org-mode manual describes how
to do this, basically

emacs -l /path/to/org.el -l /path/to/gnus-sum.el

Ok. The problem for me were in the path : the files org.el,
org-install.el, org-mouse.el and org-publish were still in the path
for emacs 22.0.51 and not in the new path for emacs 22.0.91.

However emacs 22.0.51 is no more present neither on my system, nor
in the load-path.

I copied the org-*.el in /usr/share/emacs/22.0.91/lisp/texmodes/ and
now 'C-c l' works fine.

Why is /usr/share/emacs/22.0.51/lisp/texmodes/ still present on my
machine ? I don't know. However i removed this version before loading
emacs-snapshot (22.0.91). Curious.

Because the Makefile that comes with org-mode does create the
directory where it is supposed to put those files, and obviously
you have given this specific path in the header of the Makefile.

For the ease of maintenance it may be better to install org-mode
into a directory that does not depend on the specific version of Emacs
you are using.  This could be either a directory in your own home
directory (then you would have to add the path to the Emacs load path).
Or it could be something like /usr/local/share/emacs/site-lisp - you need
to check your system to find out where the version-independent site-lisp
directory is located.

- Carsten

reply via email to

[Prev in Thread] Current Thread [Next in Thread]