[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Nick Dokos: Re: [Orgmode] org-export-generic gives an error

From: Nick Dokos
Subject: Nick Dokos: Re: [Orgmode] org-export-generic gives an error
Date: Fri, 17 Jul 2009 16:12:42 -0400

Noch einmal: I replied to srinivas and forgot to copy the list - sorry.

------- Forwarded Message

Date:    Wed, 15 Jul 2009 16:18:29 -0400
From:    Nick Dokos <address@hidden>
To:      srinivas <address@hidden>
cc:      address@hidden
Subject: Re: [Orgmode] org-export-generic gives an error 

srinivas <address@hidden> wrote:

> I am trying to test org-export-generic. I have an org file which exports 
> correctly to html but when I tried the org-export-generic, I get the followin
> error:
> === from *Messages* buffer
> and: Symbol's function definition is void: characterp
> My commands: C-c C-e g d (for demo)
> I have tried C-c C-e g a (ascii) export but returns the same error.
> Version Info:
> GNU Emacs 22.3.1 (i386-mingw-nt5.1.2600) of 2008-09-06 on SOFT-MJASON
> Org-mode version 6.28b
> Any tips on what could be causing this error.

characterp does not exist in emacs 22 (at least in 22.1.1 which is what
I have) - you can probably add a compatibility function in your .emacs,
perhaps something like this:

(if (< emacs-major-version 23)
    (defun characterp (obj)
      (and (char-or-string-p obj) (not (stringp obj)))))


------- End of Forwarded Message

reply via email to

[Prev in Thread] Current Thread [Next in Thread]