[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Orgmode] Re: Strange bug, request for more info

From: Bernt Hansen
Subject: [Orgmode] Re: Strange bug, request for more info
Date: Thu, 27 May 2010 07:39:56 -0400
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.2 (gnu/linux)

Carsten Dominik <address@hidden> writes:

> On May 26, 2010, at 4:44 AM, Bernt Hansen wrote:
>> Let me know if you can think of anything I can provide to help track
>> down this bug.
> Unfortunately, I really don't know how to fix this bug.   Until I can
> get a way to reproduce this, it will be very hard to figure out what
> is causing this.
> My suspicion is that it has to do with redisplay.  When Emacs is
> redisplaying, it will move window start in a window so that (point)
> will be visible in the buffer.  For some reason that is a complex
> combination of folding text (maybe) and the complex code that Org
> evaluates before actually showing an agenda item, it seems that the
> redisplay engine might be kicked of with a wrong idea of where point
> should be.
> In this view, the reason why Samuel is getting this error more than
> anybody else would have to do with the fact that he is using HUGE
> fonts, with very little text in a window at any given time, so that
> the "point is not in the window" condition might be triggered more
> often.
> These are wild guesses, I know that years ago I spent *many* hours
> trying to figure out what is happening her.  I still don't know.
> What you can do is make me a test case that will reproduce this
> behavior, reliably.  I think that this problem could depend on hook
> settings and on setings of the context-revealing variables like
> org-show-hierarchy-above
> org-show-following-heading
> org-show-entry-below
> org-show-siblings
> so if you are trying to make a test case, you should use the same
> values for these variables and also try to figure out if the current
> visibility state of the outline has to do with it.
> Also, does this error exist in Emacs 23?

Hi Carsten,

I don't know if this is also in Emacs 23.  I currently run two instances
of org-mode (Emacs 22 in Linux at home and Emacs 23 in Windows at work).
I'll keep an eye on it and report back if I see this behaviour in Emacs

I am not currently trying to build a test case for this bug since I
can't reproduce it at will yet.

Thanks for the descriptive analysis.  Hopefully we can squash this one
either by it being fixed in Emacs 23 or by getting a reproducible test
case that shows the problem.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]