[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Orgmode] Unable to export babel results

From: Eric Schulte
Subject: Re: [Orgmode] Unable to export babel results
Date: Tue, 19 Oct 2010 07:36:57 -0600
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.1.90 (gnu/linux)

Suvayu Ali <address@hidden> writes:

> Hi Eric,
> On Monday 18 October 2010 07:20 PM, Eric Schulte wrote:
>> Hmm,
>> Are you sure that the version of Org-mode loaded in Emacs is the very
>> same version?  What output do you get when you run the org-version
>> command?  I get
>>    Org-mode version 7.01trans (release_7.01h.747.g57e7)
> I just updated to the master HEAD, still no luck. Before and after
> updating I get this, "Org-mode version 7.01trans". I don't know why I
> have never seen the part within the parentheses before.

The part within parenthesis is pulled directly from the git repository
with the command

  git describe --abbrev=4 HEAD

Do you have git installed on your system?  If you do (which I'd think
you'd have to in order to have made it this far) then I'm not sure why
your org-version command doesn't include a part in parenthesis.  If you
really wanted to dig into this you could;
1) call describe-function on the `org-version' function
2) evaluate org-version with edebug by pressing C-u C-M-x
3) call the function with M-x org-version
4) and then step through the function by repeatedly pressing space-bar
   to see why it is failing to call git

>> It is common for people to have a local checkout of the latest version
>> of org-mode, but still have an older version located somewhere in their
>> site-lisp directory loaded overtop of the new checkout.  If this is the
>> case you may need to tweak your classpaths.
>> If you are using the latest version of Org-mode, then I'm not sure what
>> the problem could be.  I've exported your attached example file with
>> org-confirm-babel-evaluate set to both nil and to true, in both cases it
>> worked for me without problem.  Are you on a windows box (another one of
>> my go-to potential culprits)?
> I use "GNU Emacs (2010-10-15)" on Fedora 13. To install
> org-mode, I overwrite the default emacs org directory,
> $EMACS_INSTALL_PATH/share/emacs/24.0.50/lisp/org
> I know this works because after I update emacs, `org-version' returns
> "7.01h" and subsequently updating org-mode changes the version as I
> stated above. Do you think I might have mixed version of files? I used
> to install it under,
> $EMACS_INSTALL_PATH/share/emacs/site-lisp
> but I prefer having things all organised inside a directory and I am
> not confident enough to write my own site-lisp file.

It might be worthwhile removing the old install under

> FWIW, I have this same issue on a similar Ubuntu 10.04 installation of
> Emacs 24 and org-mode HEAD.

Hmm, I'm still leaning towards thinking that this could be an
installation issue.  I'd try cleaning up old versions of org-mode and
your load-path until you manage to get something like the following out
of the org-version command

  Org-mode version 7.01trans (release_7.01h.718.g0cb3c5)

My guess is that once you get there the problem will be fixed.

>> Best -- Eric
> Thanks a lot for looking into this.

Happy to Help, Best of Luck -- Eric

also, if nothing else works, another unrelated thing to try is setting
org-confirm-babel-evaluate to nil (just temporarily)

  (setq org-confirm-babel-evaluate nil)

and then trying once again to export the file.  I doubt this will fix
the problem (and I almost hope it doesn't because then I don't
understand the problem as well as I thought I did, and an actual bug is
implied), but I suppose it may be an outside possibility.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]