[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [O] Bug due to org-startup-indented

From: Gustav Wikström
Subject: Re: [O] Bug due to org-startup-indented
Date: Thu, 22 Dec 2011 16:17:15 +0100

Yes, unfortunately it also breaks with "-q". Using "toggle-debug-on-error" does not work since emacs fails. It's not reporting any error before this failure.

I've tried to debug what happens with "debug-on-entry" when calling "org-cycle". What I find is that after a call to "overlay-put" the program breaks. 

I've also tried the same procedure without enabling "org-startup-indented" and then nothing bad happens. This single change in emacs -q results in the reported behaviour for me.

Nicolas, are you using windows and emacs 24.0.92?


2011/12/22 Nicolas Goaziou <address@hidden>

Gustav Wikström <address@hidden> writes:

> When org-startup-indented is set to true I get a fatal error when using
> 'org-tree-to-indirect-buffer' on a heading then using org-cycle on the same
> heading in the indirect-buffer.
> This bug exists in org-version 7.7 & 7.8.02 in  emacs on windows.
> The following commands should reproduce the error:
> M-: (setq org-startup-indented t)
> "open an org-mode file with some headlines and text."
> C-c C-x b
> C-x 0
> tab

I cannot reproduce this on 7.8.02. Does it happen with "-q"? Does it
happen on every Org file?

Also, what is the error reported (with M-x toggle-debug-on-error)?


Nicolas Goaziou

reply via email to

[Prev in Thread] Current Thread [Next in Thread]