[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [O] Bug due to org-startup-indented

From: Nick Dokos
Subject: Re: [O] Bug due to org-startup-indented
Date: Thu, 22 Dec 2011 12:13:32 -0500

Nicolas Goaziou <address@hidden> wrote:

> Gustav Wikström <address@hidden> writes:
> > Yes, unfortunately it also breaks with "-q". Using "toggle-debug-on-error"
> > does not work since emacs fails. It's not reporting any error before this
> > failure.
> >
> > I've tried to debug what happens with "debug-on-entry" when calling
> > "org-cycle". What I find is that after a call to "overlay-put" the program
> > breaks.
> >
> > I've also tried the same procedure without enabling "org-startup-indented"
> > and then nothing bad happens. This single change in emacs -q results in the
> > reported behaviour for me.
> >
> > Nicolas, are you using windows and emacs 24.0.92?
> No, I'm using GNU/Linux and Emacs 24.0.92.
> Anyway, if emacs crashes, whatever may be the badness of Org indent
> code, the problem should be reported to the emacs devel mailing list
> instead: all that we may come up with here would be a hack.

FWIW, I cannot reproduce it either (GNU Emacs
(x86_64-unknown-linux-gnu, GTK+ Version 2.22.0) of 2011-10-27 and
Org-mode version 7.8.02 (release_7.8.02.2.g490d6a)) so the Windoze part
seems essential.

I'm not sure how much of a development environment the OP has set up on
his box, but if gdb is available, running emacs under gdb and getting a
stacktrace to report to the emacs devel list seems like the best route

BTW, is there no error message at all? emacs just dies?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]