[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [unicode-2] whitespace-auto-cleanup always replaces leading spaces w

From: Braden McDaniel
Subject: Re: [unicode-2] whitespace-auto-cleanup always replaces leading spaces with tabs
Date: Mon, 23 Apr 2007 09:10:40 +0000 (UTC)
User-agent: Pan/0.127 (Eckythump)

On Sun, 22 Apr 2007 11:16:45 +0200, martin rudalics wrote:

>> If I start with -Q and then set whitespace-global-mode to non-nil and
>  > set both whitespace-check-leading-whitespace and
>  > whitespace-check-indent-whitespace to nil, leading sequences of 8
>  > spaces still get highlighted.
> What happens if you set (customize) `whitespace-check-indent-whitespace'
> _before_ you toggle `whitespace-global-mode'?

No difference; sequences of 8 spaces in indentation are still highlighted.

>  > I see. But I think this has gotten sidetracked from the real bug that
>  > was introduced here. Indeed, the fact that
>  > whitespace-check-indent-whitespace has never done what I want is
>  > exactly the reason I have it set to nil (along with
>  > whitespace-check-leading-whitespace; I'm not clear on how these two
>  > differ).
> `whitespace-check-leading-whitespace' only serves for removing leading
> empty lines from the buffer, hence it doesn't enter here.


>  > So the bug that has been introduced recently is whatever causes
>  > whitesapce checking to flag indentation whitespace even though
>  > whitespace-check-indent-whitespace is nil.
> I'm not sure what you mean here.  Above you said that it "has never done
> what you want" here you talk about a recently introduced bug.

Two different things:

 * whitespace-check-indent-whitespace--when non-nil--doesn't play
   nicely with indent-tabs-mode; this has been the case for as long as
   I know.
 * Setting whitespace-check-indent-whitespace to nil simply doesn't
   work. That is, it doesn't turn off checking (and correcting)
   indentation whitespace.  This is (relatively) new.

> Please
> tell me whether and when this worked correctly.  I could try to track
> the changes that occurred since then.

Unfortunately I don't have a working copy around that hasn't been updated 
to a point that includes this problem. I'm not sure when I updated prior 
to my most recent update (April 1); it was a while. I'm in the process of 
checking out some older revisions to try to find when this worked; but so 
far no luck. I can say that it works with emacs 21.4.1.

Braden McDaniel                           e-mail: <address@hidden>
<http://endoframe.com>                    Jabber: <address@hidden>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]