[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gcl-devel] build errors with gcc 3.1

From: Camm Maguire
Subject: Re: [Gcl-devel] build errors with gcc 3.1
Date: 28 Jul 2002 11:38:48 -0400


"David Shochat" <address@hidden> writes:

> On 7/6, I posted build problems I got trying to build gcl 2.4.3 
> using the compiler (gcc 2.96-110) that comes with RedHat Linux 7.3. 
> Thanks to a helpful response from Camm Maguire, I was able to get 
> it to build with a minor code change. The resulting gcl worked fine 
> except that when I tried to use it with ilisp, emacs froze and had 
> to be killed. I reported this on comp.lang.lisp and ilisp-help, but 
> got no response from either.
> So I thought I would try building with gcc 3.1. Again, I get a build 
> error:
> gcc3 -pipe -fwritable-strings  -DVOL=volatile 
>  -I/usr/local/lisp/gcl/gcl-2.4.3/o -fsigned-char -c -O  
>  -I../gcl-tk -I../h/ -O4   sfasl.c  
> In file included from ../h/include.h:62,
>                  from sfasl.c:40:
> ../h/object.h:67: warning: useless keyword or type name in empty 
>  declaration
> ../h/object.h:67: warning: empty declaration
> In file included from ../h/include.h:72,
>                  from sfasl.c:40:
> ../h/att_ext.h:208: conflicting types for `GBC_enable'
> ../h/notcomp.h:9: previous declaration of `GBC_enable'
> ../h/att_ext.h:284: conflicting types for `initflag'
> ../h/notcomp.h:15: previous declaration of `initflag'
> In file included from sfaslelf.c:273,
>                  from sfasl.c:45:
> sfaslelf.c: In function `fasload':
> sfaslelf.c:136: warning: passing arg 0 of `round_up' makes 
>  integer from pointer without a cast
> make[1]: *** [sfasl.o] Error 1

OK, the straightforward fixes you suggest in your later message are
all equivalent to what I believe we've already put into cvs when we
cleaned up the build with -Wall.  So it should be safe.  As for
patching, this would refer not to the current cvs branch, but rather
to a branch separated for the 2.4.3 stable release, so this should be
handled with some care.  There are several bug fixes which should also
be merged back from current cvs into 2.4.3 if a 2.4.4 is ever
released.  What I'm trying to decide now is if it would be simpler to
have 2.5.0 be out next release, thereby saving us this effort.

> So I decided to try latest cvs. In this case, I get a different 
> build error:
> make[1]: Entering directory `/usr/local/lisp/gcl/cvs/gcl/unixport'
> make[1]: *** No rule to make target `../mp/libmport.a', 
>  needed by `raw_gcl'.  Stop.
> make[1]: Leaving directory `/usr/local/lisp/gcl/cvs/gcl/unixport'
> make: *** [all] Error 2
> Is there a known problem building gcl with gcc 3.1? Is current CVS 
> unstable?

Current cvs should be quite good.  More robust in several respects
than 2.4.3.  All the message above indicates is that the subconfigure
in the gmp directory failed.  Do a 'cd gmp ; ./configure' and try to
see what is complained about.  Everything should be just fine with
3.1.  I'd appreciate a configure and build output posted to the list,
if you have the time.

take care,

> Thanks.
> -- David
> _______________________________________________
> Gcl-devel mailing list
> address@hidden
> http://mail.gnu.org/mailman/listinfo/gcl-devel

Camm Maguire                                            address@hidden
"The earth is but one country, and mankind its citizens."  --  Baha'u'llah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]