[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gcl-devel] Re: [Maxima] Re: [Maxima-commits] CVS: maxima/src plot.lisp,

From: Vadim V. Zhytnikov
Subject: [Gcl-devel] Re: [Maxima] Re: [Maxima-commits] CVS: maxima/src plot.lisp, 1.35, 1.36
Date: Thu, 22 Apr 2004 21:57:58 +0300
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru-RU; rv:1.5) Gecko/20031006

Camm Maguire :
Greetings!  If there is any ansi feature currently implemented in gcl
2.7.0 which you would like backported to gcl 2.6.2 before we release
it, please let me know and I will consider.  In general we are too
close to release now for such items, but we have still mysterious
windows problems outstanding, which may delay the release long enough
for a simple backport to be feasible.

No, I don't think that any backports are required at present.
I hope that ANSI compliance will be the primary goal for
gcl 2.7.X and ultimately 2.8.0 (3.0.0 ?)

Take care,

"Vadim V. Zhytnikov" <address@hidden> writes:

Raymond Toy :

"Vadim" == Vadim V Zhytnikov <address@hidden> writes:

   Vadim> -                  ;; Hmm, gcl 2.5.1 does appear to have
handler-case.  Ick.     Vadim> +                     ;; GCL 2.6.2
has handler-case but not quite ANSI yet.     Vadim>
(let ((result
   Vadim>                           #-gcl
   Vadim>                            (handler-case     Vadim>
(catch 'errorsw
   Vadim>                                 ($float ($realpart (meval* ',expr))))
   Vadim>                             (arithmetic-error () t))
   Vadim> -                          #+gcl
   Vadim> -                          (catch 'errorsw
   Vadim> +                         #+gcl
   Vadim> +                          (conditions::handler-case
Vadim> +                                (catch 'errorsw
   Vadim>                                 ($float ($realpart (meval* ',expr))))
   Vadim> +                           (conditions::internal-error () t))
   Vadim>                            ))
Does this mean we no longer support versions of gcl earlier than
2.6.2?  Is that what we want?

I suppose so.

FWIW, I still use gcl 2.4.0 on my Solaris box.  Mostly because I
haven't been able to build more recent ones.  I think my Linux box
also uses 2.5.x or so, because I can't build later ones.

As far as I remember we decided to use ANSI GCL for Maxima
so 2.4.0 is certainly out of date.  I'm not 100% sure about
Solaris but I don't expect any troubles with 2.6.2
(now still 2.6.1 CVS) on Linux.

     Vadim V. Zhytnikov


reply via email to

[Prev in Thread] Current Thread [Next in Thread]