[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gcl-devel] Re: address@hidden: RE: Compiling gcl on Fedora Core 3.]

From: Matt Kaufmann
Subject: [Gcl-devel] Re: address@hidden: RE: Compiling gcl on Fedora Core 3.]
Date: Sun, 2 Jan 2005 11:53:53 -0600

Thank you, Camm.  Do you mind if I forward your reply to acl2-help?  (In the
meantime I'm adding previous contributors to this thread.)

I'm not aware of any problems that need correcting from 2.6.5 other than the
one discussed in this thread, but thank you for asking.  Hmmm, except well,
actually, you built a reader patch for me some time ago that allows putting a
package prefix in front of an arbitrary s-expression, not just a symbol.  But
2.6.5 doesn't have this patch:

  >'lisp::(a b)


  Error: The function A is undefined.
  Fast links are on: do (si::use-fast-links nil) for debugging
  Error signalled by EVAL.
  Broken at EVAL.  Type :H for Help.

Currently our AMD work cannot use GCL because we rely on this capability.
(Allegro CL is working OK, so this isn't at all critical for us, but it would
be nice to have GCL as an option.)

Thanks --
-- Matt
   cc: address@hidden
   From: Camm Maguire <address@hidden>
   Date: 27 Dec 2004 20:34:44 -0500
   User-Agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.2
   Content-Type: text/plain; charset=us-ascii
   X-SpamAssassin-Status: No, hits=-2.6 required=5.0
   X-UTCS-Spam-Status: No, hits=-332 required=180

   Greetings!  I believe this is due to a newer version of binutils
   available on FC3.  Patches are available on the website errata page.
   Alternatively, one can build with GCL's local binutils copy via
   --disable-statsysbfd --enable-locbfd.  Of course there are no real
   details below, so this is just an educated guess.  Please advise if
   problems persist.

   BTW, am considering rolling the errata page patches plus a few minor
   changes for axiom into a 2.6.6.  If you have any other suggestions of
   minimal changes which should go in I'd be most appreciative. Major
   work these days is confined to cvs head (aka 2.7.0).

   Take care,

   Matt Kaufmann <address@hidden> writes:

   > Hi, Camm --
   > If you know anything about this, please feel free to enlighten us!
   > Thanks --
   > -- Matt
   > From: "David L. Rager" <address@hidden>
   > Subject: RE: Compiling gcl on Fedora Core 3.
   > To: <address@hidden>, <address@hidden>
   > Date: Thu, 23 Dec 2004 11:38:00 -0600
   > Reply-To: address@hidden
   > Hello Sandip,
   > I too tried for a couple hours to get this to work. Please let me know
   > if you figure it out. For the moment, I gave up and went with the
   > prebuilt image of gcl that I found in an rpm at an obscure website. 
   > The filename is: gcl-2.6.5-0.fdr.1.2.i386.rpm.
   > A website that has it is
   > http://apt.kde-redhat.org/yum/fedora/2/RPMS.stable/
   > The same person that compiles GCL for these images already has some
   > images for other Fedora 3 programs, so maybe he is also running into
   > problems with compiling GCL on Fedora 3.
   > Once you get a version of GCL working could you please let me know if
   > you get ACL2 building successfully? I had to download a prebuilt image
   > of that too, but I haven't spent a huge amount of time on it (and I am a
   > Newb in terms of Fedora Linux file system arrangement).
   > Thanks,
   > David
   > - -----Original Message-----
   > From: address@hidden
   > [mailto:address@hidden On Behalf Of Sandip Ray
   > Sent: Thursday, December 23, 2004 10:47 AM
   > To: address@hidden
   > Subject: Compiling gcl on Fedora Core 3.
   > Hello,
   > I was trying to compile gcl 2.6.5 on Fedora Core 3, and I am running
   > into
   > errors. I am not sure what I need to do so I was thinking if someone
   > over
   > here can help me. I am attaching the complete log of the run of make
   > with
   > this email.
   > I admit I am a complete newbie in this, but the couple of times I had
   > tried it before it worked without any problems.
   > Interestingly, the pre-built ACL2 image for Debian works perfectly for
   > my system. In case this is relevant, the gcc version in my machine is
   > 3.4.2.
   > Thanks in advance,
   > Sandip.
   > ----------

   Camm Maguire                                         address@hidden
   "The earth is but one country, and mankind its citizens."  --  Baha'u'llah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]