[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnash-dev] Re: NetStream-SquareTest.swf failures with ffmpeg

From: Hong Yu
Subject: Re: [Gnash-dev] Re: NetStream-SquareTest.swf failures with ffmpeg
Date: Wed, 09 Apr 2008 15:50:52 +0800
User-agent: Thunderbird (X11/20080213)

Gnash-cvs on my workstation can generally play NetStream-SquareTest.swf now, even only partially (red rectangle not moving). So I may not help with why no video shown up. Yes, ffmpeg media handler use thread.

We have used gnash0.8.2 to build with FFmpeg newer than Feb 18, 2008. And we have found that, very recent FFmpeg use expression/macro in defining 'LIBAVCODEC_VERSION' in avcodec.h, which caused Gnash0.8.2 build to fail in defining 'FFMPEG_AUDIO2' and 'HAVE_SWSCALE_H' in gnashconfig.h. Gnash0.8.2 works fine when 'LIBAVCODEC_VERSION' is defined with string only (e.g., '51.50.1') in avcodec.h of FFmpeg. If you haven't handled such since gnash0.8.2, then very likely the potential problem is with current Gnash HEAD, too. Maybe you want to delay the bug report after you will have tried Gnash-cvs with newest FFmpeg? We are using FFmpeg source checked out on Feb 18, 2008.

Best regards,

Hong Yu

Sandro Santill wrote:
On Wed, Apr 09, 2008 at 12:46:19PM +0800, Hong Yu wrote:
We have been concentrated on AGG graphics-rendering related SWF display, and seen the difference between the default '-g -O2' build and '-O3' build with some heavy animation SWF. But FFmpeg option uses SDL rendering, so might be different, and my previous guess only because I saw the NetStream-SquareTest.swf color display in Gnash-cvs with '-O3'. With the default build of Gnash-cvs (April 7, 2008), I remember seeing the rectangular shape with and/or without color, with many tries.

Sounds like a race condition to me, does the ffmpeg media handler uses
threads ?

On Ubuntu6.10-Edgy, we built FFmpeg '51.50.1' (libavcodec) with the source checked out after January 2008 and no later than February 18, 2008. Gnash build encountered error in generating gnashconfig.h for FFmpeg newer than Feb 2008, due to LIBAVCODEC_VERSION in avcodec.h.

You mean current HEAD doesn't build against 51.50.1 ?
Could you file a bug if this is the case ?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]