[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gnash-dev] make error: file not recognized:

From: Ziv Chin
Subject: [Gnash-dev] make error: file not recognized:
Date: Mon, 5 Jan 2009 00:47:13 -0800


I am new to embedded linux and try to cross-compile gnash 0.8.4 in Debian. Configure is ok after I got all the require package using apt-cross. But found error in make step:

~/projects/gnash$./configure --prefix=/usr/arm --host=arm-none-linux-gnueabi --target=arm-none-linux-gnu --disable-plugin --build=i686-pc-linux-gnu --with-top-level=/usr/arm-linux-gnu
configure: This build is setup for cross compiling

        WARNING: No PNG library development package installed!
                 Gnash will be built without support for dynamic loading of PNG files.
                 Install it from
                 or .deb users: apt-get install libpng12-dev
                 or .rpm users: yum install libpng-devel
        RECOMMENDED: If the user has not installed the necessary Gstreamer plugins,
                     Gstreamer can pop up a message prompting them to.
                     Install gstpbutils from for that to be enabled
                     or .deb users: apt-get install libgstreamer-plugins-base0.10-dev
        WARNING: without --enable-docbook we will use the cached
                 documentation files included in the gnash distribution.
                 If you change files in doc/C, you should --enable-docbook.
        RECOMMENDED: If you install the CURL library, Gnash will be able to
                     display remote content (streaming from URLs) using CURL.
                     Install libcurl from
                     or .deb users: apt-get install libcurl3-dev
                     or .rpm users: yum install curl-devel
        WARNING: You need the dejagnu package installed to get a summary
                 report after running ''make check''
                 Install it from
                 or .deb users: apt-get install dejagnu

Gnash should still compile even with these warnings.  If it doesn't,
report the warnings as a bug.

/usr/arm-linux-gnueabi/lib/ file not recognized: File format not recognized
collect2: ld returned 1 exit status
make[2]: *** [] Error 1
make[2]: Leaving directory `/home/zhchin/projects/gnash/gnash-0.8.4/libbase'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/zhchin/projects/gnash/gnash-0.8.4'
make: *** [all] Error 2

I don't know what's wrong here. Can somebody plase help?

The gcc version is CodeSourcery 2006q3.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]