[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnash-dev] Re: ffmpeg config

From: strk
Subject: Re: [Gnash-dev] Re: ffmpeg config
Date: Mon, 9 Aug 2010 00:33:23 +0200

On Sun, Aug 08, 2010 at 03:16:04PM -0700, John Gilmore wrote:
> Blundering around trying things, I was able to configure with:
>   ./configure --enable-gui=gtk --enable-media=gst,ffmpeg
> [The ./configure doc should be revised to let people know that they can
>  enable more than one media option.]
> The first time, it complained:
>         ERROR: No FFMPEG development package installed!
>                You can install FFMPEG from
>                or .deb users: apt-get install libavformat-dev
>                or .rpm users: yum install ffmpeg-devel
>                or reconfigure with --enable-media=gst
>  configure: error: Please install required packages
> So I installed that, and the second time, it complained again:
>         ERROR: You have version 52.20.1 of ffmpeg installed,
>                with no swscale enabled.
>                This setup isn't supported!
>                Version 51.11.0 or newer is required, enabling swscale if >= 
> 52.0.0.
>                You can install libswscale from
>                or .deb users: apt-get install libswscale-dev
>  configure: error: Please install required packages
> It should have suggested this (at least for "deb users") the first
> time.  And when suggesting that people compile and install ffmpeg from
> scratch, it would be useful to tell them what options you require enabled
> in such a build -- the first time around.

If you install ffmpeg manually you can build swscale internally to ffmpeg
in which case libswscale shouldn't be needed, also you don't need
swscale if ffmpeg is < 52.0.0.


  ()   Free GIS & Flash consultant/developer

reply via email to

[Prev in Thread] Current Thread [Next in Thread]