[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnu-arch-users] Re: [arch-users] problem with tla on freebsd

From: Jan Hudec
Subject: Re: [Gnu-arch-users] Re: [arch-users] problem with tla on freebsd
Date: Thu, 21 Aug 2003 10:23:30 +0200
User-agent: Mutt/1.5.4i

On Wed, Aug 20, 2003 at 03:00:54PM +0000, address@hidden wrote:
> On Mon, 18 Aug 2003 20:25:55 +0200, Patrick Mauritz <address@hidden> wrote:
> >On Mon, Aug 18, 2003 at 09:51:24AM -0700, Miles Egan wrote:
> >> Error calling `vu_lstat' for "INSTALL" (No such file or directory)
> >> PANIC: I/O error
> >> 
> >> The file INSTALL definitely exists.  This doesn't happen to me when I do
> >> the same operations on Linux.
> >I had that problem with netbsd when I didn't use gnu patch, diff and tar..
> >you can set up tla to use them somehow, but try a directory with symlinks
> >gpatch -> patch etc. first, which you put in front of your PATH - probably
> >it works then..
> I've tried this on one of my afflicted FreeBSD systems, and that does
> work.  However, it's what I would refer to as a gross and unsatisfying
> hack.
> The underlying problem is that tla has hard-coded notions about what
> the names of these programs are; it looks for "patch", "diff" and
> "tar".  However, on FreeBSD the standard names are, respectively,
> "gpatch", "gdiff", and "gtar", so as not to conflict with their BSD
> counterparts.
> Ideally, this would get sorted out by the "configure" script at
> compile time, or else perhaps specified in =meta-info somehow.

It IS supposed to be sorted out by configure, just you have to do it
manualy. Try configuring with:

../configure --with-gnu-diff=gdiff --with-gnu-patch=gpatch --with-gnu-tar=gtar

And tell us if it solved the problem (I agree that it should be used as
default if BSD is detected).

                                                 Jan 'Bulb' Hudec 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]