[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gnu-arch-users] Re: Fatal bug in tla?

From: Andreas Fuchs
Subject: [Gnu-arch-users] Re: Fatal bug in tla?
Date: Fri, 12 Dec 2003 00:59:05 +0100
User-agent: Wanderlust/2.11.20 (Wonderwall) Emacs/21.3 Mule/5.0 (SAKAKI)

On 2003-12-11, Samuel Tardieu <address@hidden> wrote:
> diff - GNU diffutils version 2.7
> F*cking FreeBSD.
> Roberto, any chance to use a more recent version in -STABLE? (why do
> this look like a recurring discussion?)

I use the version from ports; gdiff 2.8.1 seems to be in there since
somewhere around last October. The downside is that you have to
specify --with-gnu-diff=gdiff to tla's configure.

> Tom, could tla's configure use gpatch/gdiff if they are present
> instead of patch/diff? Or could it at least take an option for
> setting the programs to use?

I tried to write the config-time checking that Tom suggested, but it
ended in creepy things (like echo `eval $FOO` - ugh). I believe that
it's not easy without rewriting bigger parts of package-framework, but
I couldn't bring myself to do that. (-:

> In the meantime, I'll symlink /usr/local/bin/diff -> gdiff and
> things will be ok.

That will work.

> If you know how to reproduce the problem, it would be great to add a
> test: I just tried the whole test suite, and it passed just fine :/
> (unless it doesn't stop on error)

in diff-bug/, this should be a sufficient test for the bug:

$DIFF -u BUG BUG2 | grep '^\\ No newline at end of file' >/dev/null

I haven't done a tla test case for this, though.

Have fun,
Andreas Fuchs, <address@hidden>, address@hidden, antifuchs

reply via email to

[Prev in Thread] Current Thread [Next in Thread]