[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnu-arch-users] Getting clueless win32 users working on a project i

From: John A Meinel
Subject: Re: [Gnu-arch-users] Getting clueless win32 users working on a project in arch
Date: Thu, 03 Feb 2005 18:21:56 -0600
User-agent: Mozilla Thunderbird 1.0 (Windows/20041206)

Erik de Castro Lopo wrote:

On Thu, 03 Feb 2005 08:41:53 -0600
John A Meinel <address@hidden> wrote:

I can promise you that my work is Cygwin and not mingw.

Ooops, my mistake. Sorry.

I can also tell that this isn't the actual binary that I released, since the paths don't look like what I generate.

First, get the binary from:
It is tla.exe.bz2 (bzipped to save time)

OK, I just grabbed that, bunzip2ed it, and dropped it in the Cygwin bin
directory. Here's what I get:

   address@hidden /cygdrive/c/
   $ tla register-archive
   Registering archive: address@hidden

   address@hidden /cygdrive/c/
   tla get address@hidden/libsndfile--hack lsf
   * from archive cached: address@hidden/libsndfile--hack--0--base-0
   * patching for revision: address@hidden/libsndfile--hack--0--patch-1
   arch_apply_changeset: internal error (patch (1) returned odd status)
      patch(1) exit status: 3

   PANIC: arch_apply_changeset: execvp for patch returned to caller

This archive is know to work from Linux and MaxOSX machines :-).
My Cygwin installation was updated within the last month.
Well, I just did the same test and it worked fine here (with a revision library and without).

There is one thing. Are you running on FAT32 or NTFS? If you right click on a drive and say properties, it will tell you the filesystem. At one point I thought that tla didn't work on FAT32 because it doesn't have certain info needed for inode signatures. I just tried running on both and it worked fine, though.

Now it is possible that the uploaded file is slightly older that the one I am using, I looked into setting up everything as a proper cygwin package while I was doing dev work, and I never finished it. So I did just upload the binary that I am using right now.

If you want, you can use the cygwin setup program to get it. I have the cygwin repository at

Basically, when you run setup.exe when it asks you what mirror you want to use, add a new one with the above path. Then you should have tla as an package you can install.

Are there any other changes in your Cygwin repository that would not exist
in the default Cygwin installation?

Not really. The only thing that is really there is the tla binary, and it makes sure that you have some dependencies fulfilled. Are you sure that you have patch, etc installed? Because the default install doesn't do a lot of the dev packages. I believe you need the sh-utils, diffutils, and tar packages.

If you want to give it a try and let me know if it works for you. I have found cases where it still fails if the project names are too long. But libsndfile--mdev--1.0 shouldn't have any problems.

Well, if nothing else, at least I supplied you with another data point :-).

Hopefully we'll get it figured out, since it is working for me. :)


Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]